tripledes 2.0.1

  • README.md
  • Installing
  • Versions
  • 42

tripledes-dart

Triple DES and DES block cipher implementation ported from CryptoJS

Build Status

This is ported from CryptoJS. The latest version can be found bryx/cryptojs or sytelus/CryptoJS

Example

import 'package:tripledes/tripledes.dart';

main() {
  var key = "cipher";
  var blockCipher = new BlockCipher(new DESEngine(), key);
  var message = "Driving in from the edge of town";
  var ciphertext = blockCipher.encodeB64(message);
  var decoded = blockCipher.decodeB64(ciphertext);

  print("key: $key");
  print("message: $message");
  print("ciphertext (base64): $ciphertext");
  print("decoded ciphertext: $decoded");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tripledes: ^2.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tripledes/tripledes.dart';
  
Version Uploaded Documentation Archive
2.0.1 Sep 7, 2017 Go to the documentation of tripledes 2.0.1 Download tripledes 2.0.1 archive
2.0.0 Jun 30, 2017 Go to the documentation of tripledes 2.0.0 Download tripledes 2.0.0 archive
1.0.1 Jun 28, 2017 Go to the documentation of tripledes 1.0.1 Download tripledes 1.0.1 archive
1.0.0 Jun 28, 2017 Go to the documentation of tripledes 1.0.0 Download tripledes 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
83
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0