trmsta_flutter 0.1.2

  • Installing
  • Versions
  • 30

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  trmsta_flutter: "^0.1.2"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:trmsta_flutter/trmsta.dart';
  
Version Uploaded Documentation Archive
0.1.2 Sep 4, 2016 Go to the documentation of trmsta_flutter 0.1.2 Download trmsta_flutter 0.1.2 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
89 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
15 / 100
Overall score:
Weighted score of the above. [more]
30
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: flutter.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 3 hints.

    Strong-mode analysis of lib/src/download.dart failed with the following error:

    line: 3 col: 8
    Target of URI doesn't exist: 'package:flutter/http.dart'.

    Run flutter format to format lib/src/datapars.dart.

    Similar analysis of the following files failed:

    • lib/src/dtype.dart (hint)
    • lib/src/pars.dart (hint)
  • Package is getting outdated.

    The package was released 93 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use trmsta_flutter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
flutter 0.0.20