trust_fall 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new66

trust_fall #

A Flutter plugin for detecting the trust fall of the device(Jailbroken, root, emulator and mock location detection).

Uses RootBeer for Android root detection and DTTJailbreakDetection for iOS jailbreak detection. Inspired by jail-monkey and this blog article

Getting Started #

In your flutter project add the dependency:

dependencies:
  ...
  trust_fall: ^1.0.0

Usage #

Importing package #

import 'package:trust_fall/trust_fall.dart';

Using it #

Checks whether device JailBroken on iOS/Android?

bool isJailBroken = await TrustFall.isJailBroken;

Can this device mock location - no need to root!

bool canMockLocation = await TrustFall.canMockLocation;

Checks whether device is real or emulator

bool isRealDevice = await TrustFall.isRealDevice;

(ANDROID ONLY) Check if application is running on external storage

bool isOnExternalStorage = await TrustFall.isOnExternalStorage;

Check if device violates any of the above

bool isTrustFall = await TrustFall.isTrustFall;

Note: #

❗Since emulators are usually rooted, you might want to bypass these checks during development. Unless you're keen on constant false alarms ⏰ #

1.0.1 #

  • Removed default platformVersion functionality
  • Made changes in to test file

1.0.0 #

  • Added comments
  • Changed README.md

0.0.1 #

  • Initial Release

example/README.md

trust_fall_example #

Demonstrates how to use the trust_fall plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  trust_fall: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:trust_fall/trust_fall.dart';
  
Version Uploaded Documentation Archive
1.0.1 Mar 28, 2019 Go to the documentation of trust_fall 1.0.1 Download trust_fall 1.0.1 archive
1.0.0 Mar 28, 2019 Go to the documentation of trust_fall 1.0.0 Download trust_fall 1.0.0 archive
0.0.1 Mar 24, 2019 Go to the documentation of trust_fall 0.0.1 Download trust_fall 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/trust_fall.dart.

Run flutter format to format lib/trust_fall.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test