ts_definition 1.0.0-beta

  • README.md
  • Installing
  • Versions
  • 0


Parse TypeScript interfaces, and generate (de)serializable Dart classes. Preserves comments from the original TypeScript sources.

Use the TypeScriptDefinitionTranspilerBuilder found in package:ts_definition/builder.dart.

I don't expect this library to be 100% perfect, but it was capable of generating automatic, serializable Dart files for the entire Language Server Protocol. This should be a good bet for many projects.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate ts_definition

2. Use it

The package has the following executables:

$ ts_definition

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ts_definition: ^1.0.0-beta

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:ts_definition/ts_definition.dart';
Version Uploaded Documentation Archive
1.0.0-beta Jul 30, 2017 Go to the documentation of ts_definition 1.0.0-beta Download ts_definition 1.0.0-beta archive
1.0.0-alpha+2 Jul 30, 2017 Go to the documentation of ts_definition 1.0.0-alpha+2 Download ts_definition 1.0.0-alpha+2 archive
1.0.0-alpha+1 Jul 30, 2017 Go to the documentation of ts_definition 1.0.0-alpha+1 Download ts_definition 1.0.0-alpha+1 archive
1.0.0-alpha Jul 30, 2017 Go to the documentation of ts_definition 1.0.0-alpha Download ts_definition 1.0.0-alpha archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because ts_definition depends on antlr4dart >=0.1.1 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format bin/main.dart.

Run dartfmt to format bin/main.dart.

Format lib/src/analysis/analysis.dart.

Run dartfmt to format lib/src/analysis/analysis.dart.

Format lib/src/dart/dart.dart.

Run dartfmt to format lib/src/dart/dart.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/grammar/ts_interface_base_listener.dart (Run dartfmt to format lib/src/grammar/ts_interface_base_listener.dart.)
  • lib/src/grammar/ts_interface_lexer.dart (Run dartfmt to format lib/src/grammar/ts_interface_lexer.dart.)
  • lib/src/grammar/ts_interface_listener.dart (Run dartfmt to format lib/src/grammar/ts_interface_listener.dart.)
  • lib/src/grammar/ts_interface_parser.dart (Run dartfmt to format lib/src/grammar/ts_interface_parser.dart.)
  • lib/ts_definition.dart (Run dartfmt to format lib/ts_definition.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-36.44 points)

The package was released 71 weeks ago.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use ts_definition.dart. Packages with multiple examples should use example/readme.md.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0