tts 1.0.1

  • Example
  • Installing
  • Versions
  • 54


A text to speech plugin for flutter. Initial implementation, more to come. :)


To use this plugin, add tts as a dependency in your pubspec.yaml file.


import 'package:flutter/material.dart';
import 'package:url_launcher/url_launcher.dart';

void main() {
  runApp(new Scaffold(
    body: new Center(
      child: new RaisedButton(
        onPressed: speak,
        child: new Text('Say Hello'),

speak() async {
  Tts.speak('Hello World');


You can get a list of available languages (voices) supported by the OS by calling:

final languages = await Tts.getAvailableLanguages();

Checking to see if a languge can be used:

var isGoodLanguage = await Tts.isLanguageAvailable(lang);

Setting a deisred language:

var setLanguage = await Tts.setLanguage(lang);

[1.0.1] - 2/5/2018.

  • Minor bug fix.

[1.0.0] - 2/5/2018.

  • Adding ability to change languages.

[0.0.2] - 2/4/2018.

  • Android bug fix.

[0.0.1] - 2/4/2018.

  • initial release with basic speech functionality.


import 'package:flutter/material.dart';
import 'package:tts/tts.dart';
import 'dart:math';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
final TextEditingController speechTextController = new TextEditingController();
String languageAvailableText = '';
List<String> languages;
Random rng = new Random();
  initState() {

  // Platform messages are asynchronous, so we initialize in an async method.
  initPlatformState() async {
    // Platform messages may fail, so we use a try/catch PlatformException.
    languages = await Tts.getAvailableLanguages();
    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted)

  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        body: new Center(
          child: new Column(
            children: <Widget>[
              new TextField(
                controller: speechTextController,
              new MaterialButton(
                  onPressed: () async{
                    var lang = languages[rng.nextInt(languages.length-1)];
                    var isGoodLanguage = await Tts.isLanguageAvailable(lang);
                    var setLanguage = await Tts.setLanguage(lang);
                child: new Text('Do Speak'),
              new Text(languageAvailableText)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  tts: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:tts/tts.dart';
Version Uploaded Documentation Archive
1.0.1 Feb 6, 2018 Go to the documentation of tts 1.0.1 Download tts 1.0.1 archive
1.0.0 Feb 6, 2018 Go to the documentation of tts 1.0.0 Download tts 1.0.0 archive
0.0.2 Feb 4, 2018 Go to the documentation of tts 0.0.2 Download tts 0.0.2 archive
0.0.1 Feb 4, 2018 Go to the documentation of tts 0.0.1 Download tts 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 22, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0-dev.5.0.flutter-4cf2d3990b.
 Because tts requires SDK version >=1.8.0 <=2.0.0, version solving failed.

Health suggestions

Format lib/tts.dart.

Run flutter format to format lib/tts.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <=2.0.0