A command-line tool to manipulate and inspect your Dart projects.
To install, run:
pub global activate tuneup
tuneup --help (or
pub global run tuneup --help) to see a list of available commands.
Then run a tuneup command, like
pub global run tuneup check
from the root of your project.
Please file reports on the GitHub Issue Tracker.
This is not an official Google product.
--client-idfield into the analysis server
checkcommand to be based on the analysis server
0.30.0-alpha.1of the analyzer
// ignore: foo_barcomments)
0.28.1of the analyzer
checkcommand on windows
--directoryflag to support analyzing something besides the current working directory
checkthe default command
You can install the package from the command line:
$ pub global activate tuneup
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: tuneup: "^0.3.4"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.3.4||Jun 15, 2018|
|0.3.3||Apr 7, 2018|
|0.3.2+2||Dec 1, 2017|
|0.3.2+1||Dec 1, 2017|
|0.3.2||Dec 1, 2017|
|0.3.1+3||Jun 3, 2017|
|0.3.1+2||May 27, 2017|
|0.3.1+1||May 24, 2017|
|0.3.1||May 10, 2017|
|0.3.0||Apr 23, 2017|
We analyzed this package on Jun 15, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.23.0 <2.0.0|