tw_saved_search_angular 0.0.1

  • CHANGELOG.md
  • Installing
  • Versions
  • 42

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tw_saved_search_angular: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:tw_saved_search_angular/tw_saved_search_angular.dart';
  
Version Uploaded Documentation Archive
0.0.1 Sep 21, 2017 Go to the documentation of tw_saved_search_angular 0.0.1 Download tw_saved_search_angular 0.0.1 archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
61 / 100
Overall score:
Weighted score of the above. [more]
42
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running pub upgrade failed with the following output:

    ERR: Could not resolve URL "http://crp-bld-01.trustwave.com:8085".
    
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Fix dependencies in pubspec.yaml.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Homepage does not exists.

    We were unable to access https://wiki.trustwave.com/display/eng/Portal+NG+-+UI+Components at the time of the analysis.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use tw_saved_search_angular.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 hints.

    Run dartfmt to format lib/src/common/model.dart.

    Run dartfmt to format lib/src/common/model.g.dart.

    Similar analysis of the following files failed:

    • lib/src/common/service.dart (hint)
    • lib/src/ui/saved_search/saved_search.dart (hint)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0