twirp_dart_core 1.0.0+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new61

Core library for using Twirp with Dart

More information about the Twirp for Dart generator

Usage

If you have a project using Twirp for Dart, you must import this library into your pubspec.yaml

dependencies:
    twirp_dart_core: any

Features and bugs

Please file feature requests and bugs at the issue tracker.

1.0.0

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  twirp_dart_core: ^1.0.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:twirp_dart_core/twirp_dart_core.dart';
  
Version Uploaded Documentation Archive
1.0.0+1 Nov 28, 2018 Go to the documentation of twirp_dart_core 1.0.0+1 Download twirp_dart_core 1.0.0+1 archive
1.0.0 Nov 28, 2018 Go to the documentation of twirp_dart_core 1.0.0 Download twirp_dart_core 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:twirp_dart_core/twirp_dart_core.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use twirp_dart_core.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
http ^0.11.0 0.11.3+17 0.12.0
requester >=0.0.2 <2.0.0 1.0.0
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
Dev dependencies
test ^1.0.0