twit 0.0.4

  • Installing
  • Versions
  • 58


version 0.0.4 build status

Dart port of Tolga Tezel's Twitter client.

import 'dart:convert';
import 'package:twit/io.dart';

main() async {
    var twit = new Twit(
        new Credentials(consumerKey: ..., consumerSecret: ..., accessToken: ..., accessTokenSecret: ...));
    var stream ='');

    stream.listen((tweet) {
        print('Incoming Tweet: ' + tweet['text']);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  twit: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:twit/twit.dart';
Version Uploaded Documentation Archive
0.0.4 Mar 17, 2017 Go to the documentation of twit 0.0.4 Download twit 0.0.4 archive
0.0.3 Mar 12, 2017 Go to the documentation of twit 0.0.3 Download twit 0.0.3 archive
0.0.2 Mar 11, 2017 Go to the documentation of twit 0.0.2 Download twit 0.0.2 archive
0.0.1 Feb 25, 2017 Go to the documentation of twit 0.0.1 Download twit 0.0.1 archive
0.0.0 Feb 25, 2017 Go to the documentation of twit 0.0.0 Download twit 0.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Aug 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 Because twit depends on random_string any which requires SDK version >=1.0.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.


Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see

Package is getting outdated.

The package was released 74 weeks ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use twit.dart.

Format lib/src/apis/account.dart.

Run dartfmt to format lib/src/apis/account.dart.

Format lib/src/apis/apis.dart.

Run dartfmt to format lib/src/apis/apis.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/client.dart (Run dartfmt to format lib/src/client.dart.)
  • lib/src/data/data.dart (Run dartfmt to format lib/src/data/data.dart.)
  • lib/src/data/exception.dart (Run dartfmt to format lib/src/data/exception.dart.)
  • lib/src/data/twitter_data.dart (Run dartfmt to format lib/src/data/twitter_data.dart.)
  • lib/twit.dart (Run dartfmt to format lib/twit.dart.)