ulid 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 86

Ulid implementation in Dart

Lexicographically sortable, 128-bit identifier (UUID) with 48-bit timestamp and 80 random bits. Canonically encoded as a 26 character string, as opposed to the 36 character UUID.

Original implementation: https://github.com/alizain/ulid/

Usage

A simple usage example:

import 'package:ulid/ulid.dart';

main() {
  print(new Ulid());
  print(new Ulid().toUuid());
}

Changelog

1.0.1

  • Declared support for Dart 2.
  • Upgraded dependencies.

1.0.0

  • First public version.

example/main.dart

// Copyright (c) 2017, Agilord. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:ulid/ulid.dart';

void main() {
  print(new Ulid());
  print(new Ulid().toUuid());
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ulid: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ulid/ulid.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jul 25, 2018 Go to the documentation of ulid 1.0.1 Download ulid 1.0.1 archive
1.0.0 Jun 9, 2017 Go to the documentation of ulid 1.0.0 Download ulid 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:ulid/ulid.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
Dev dependencies
test ^1.0.0