unpub 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new32

Unpub #

pub

Private Dart Pub for Enterprise.

Usage #

Via command line #

pub global activate unpub

Then run it:

unpub

It will use file system as meta store and package(tarball) store

Via Dart API #

import 'package:unpub/unpub.dart';

var baseDir = path.absolute('unpub-data');

var repository = UnpubRepository(
  metaStore: UnpubFileMetaStore(baseDir),
  // You can also use MongoDB as meta store
  // metaStore: await UnpubMongo.connect('mongodb://localhost:27017/dart_pub'),

  packageStore: UnpubFilePackageStore(baseDir),

  shouldCheckUploader: true,
);

var server = UnpubServer(repository);
server.serve('0.0.0.0', 3000);

License #

MIT

0.0.1 #

  • Initial version, created by Stagehand

0.1.0 #

  • pub get
  • pub publish with permission check

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate unpub

2. Use it

The package has the following executables:


$ unpub

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  unpub: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:unpub/unpub.dart';
  
Version Uploaded Documentation Archive
0.1.0 Apr 16, 2019 Go to the documentation of unpub 0.1.0 Download unpub 0.1.0 archive
0.0.1 Apr 6, 2019 Go to the documentation of unpub 0.0.1 Download unpub 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
3
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

We analyzed this package on Apr 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:unpub/unpub.dart with components: io.

Maintenance issues and suggestions

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: pub_server.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and unpub.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
archive ^2.0.8 2.0.8
args ^1.5.1 1.5.1
googleapis ^0.53.0 0.53.0
http ^0.12.0 0.12.0+2
json_annotation ^2.1.0 2.2.0
logging ^0.11.3 0.11.3+2
meta ^1.1.7 1.1.7
mongo_dart ^0.3.4 0.3.5
pub_semver ^1.4.2 1.4.2
pub_server 0.1.6-dev
shelf ^0.7.5 0.7.5
yaml ^2.1.15 2.1.15
Transitive dependencies
_discoveryapis_commons 0.1.8+1
async 2.2.0
bson 0.3.2
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
fixnum 0.10.9
http_parser 3.1.3
mime 0.9.6+2
mongo_dart_query 0.3.2
more 1.16.0
path 1.6.2
pool 1.4.0
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
uuid 2.0.1
Dev dependencies
build_runner ^1.0.0
json_serializable ^2.0.0
pedantic ^1.0.0 1.5.0
test ^1.6.1