upnp 2.0.0+1

  • README.md
  • Installing
  • Versions
  • 67

UPnP Client for Dart #

Features #

  • Discovery
  • Device Information
  • Services
  • Actions
  • Host Support
  • DIAL API
  • Router API

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  upnp: ^2.0.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:upnp/upnp.dart';
  
Version Uploaded Documentation Archive
2.0.0+1 Sep 15, 2018 Go to the documentation of upnp 2.0.0+1 Download upnp 2.0.0+1 archive
2.0.0 Sep 15, 2018 Go to the documentation of upnp 2.0.0 Download upnp 2.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
59
Health:
Code health derived from static analysis. [more]
85
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Apr 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:upnp/upnp.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

280 out of 280 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/discovery.dart. (-4.89 points)

Analysis of lib/src/discovery.dart reported 10 hints, including:

line 13 col 26: Use = to separate a named parameter from its default value.

line 13 col 43: Use = to separate a named parameter from its default value.

line 156 col 21: Use = to separate a named parameter from its default value.

line 168 col 5: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 176 col 21: Use = to separate a named parameter from its default value.

Fix lib/src/server/server.dart. (-3.45 points)

Analysis of lib/src/server/server.dart reported 7 hints, including:

line 23 col 9: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 33 col 7: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 50 col 9: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 56 col 9: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 76 col 9: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Fix lib/src/sub_manager.dart. (-2.48 points)

Analysis of lib/src/sub_manager.dart reported 5 hints:

line 43 col 7: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 138 col 5: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 195 col 5: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 239 col 9: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 270 col 7: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Fix additional 12 files with analysis or formatting issues. (-4.49 points)

Additional issues in the following files:

  • lib/src/router/router.dart (4 hints)
  • lib/src/server/action.dart (2 hints)
  • lib/src/server/utils.dart (2 hints)
  • lib/src/dial/screen.dart (1 hint)
  • lib/src/action.dart (Run dartfmt to format lib/src/action.dart.)
  • lib/src/device.dart (Run dartfmt to format lib/src/device.dart.)
  • lib/src/helpers.dart (Run dartfmt to format lib/src/helpers.dart.)
  • lib/src/media/sources.dart (Run dartfmt to format lib/src/media/sources.dart.)
  • lib/src/server/device.dart (Run dartfmt to format lib/src/server/device.dart.)
  • lib/src/server/discovery.dart (Run dartfmt to format lib/src/server/discovery.dart.)
  • lib/src/service.dart (Run dartfmt to format lib/src/service.dart.)
  • lib/src/utils.dart (Run dartfmt to format lib/src/utils.dart.)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and upnp.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
crypto ^2.0.6 2.0.6
xml ^3.2.0 3.4.1
Transitive dependencies
charcode 1.1.2
collection 1.14.11
convert 2.1.1
petitparser 2.2.1
typed_data 1.1.6