urban_api 1.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new46

urban-api Pub documentation

Wrapper for UrbanDictionary api to easy access to its resources.

Usage

Library contains only one method getDefinitions(String word) to get definitions for specified word

// Get definitions for word
var res = await getDefinitions("shit");

print("Authors of definitions");
for(var i in res)
  print("== ${i.author}");

1.0.0

  • Initial version, created by Stagehand

example/urban_api_example.dart

import 'package:urban_api/urban_api.dart';

main() async {
  // Get definitions for word
  var res = await getDefinitions("shit");

  print("Authors of definitions");
  for (var i in res) print("== ${i.author}");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  urban_api: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:urban_api/urban_api.dart';
  
Version Uploaded Documentation Archive
1.0.2 Sep 23, 2018 Go to the documentation of urban_api 1.0.2 Download urban_api 1.0.2 archive
1.0.1 Sep 23, 2018 Go to the documentation of urban_api 1.0.1 Download urban_api 1.0.1 archive
1.0.0 Sep 23, 2018 Go to the documentation of urban_api 1.0.0 Download urban_api 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:urban_api/urban_api.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.12.0 0.12.0
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6