user_environment 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 16

travis build

User Environment

This package allows to detect the platform and the browser version used to view a web page.

Differentiated browsers are: IE, Edge, Chrome, Safari, Firefox, Opera, Electron, Other along with Mac, Windows and Other platforms.

Usage

  import 'package:user_environment/user_environment.dart';
  void main() {
    UserEnvironment env = UserEnvironmentFactory();
    print([
      env.browser.type,
      env.browser.version?.value,
      env.browser.getFeatureVersion('AppleWebKit'),
      env.platform.type
    ]);
  }

Running tests

pub serve test pub run test -p chrome

Changelog

1.0.1

  • Published version

1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  user_environment: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:user_environment/user_environment.dart';
  
Version Uploaded Documentation Archive
1.0.1 Dec 4, 2017 Go to the documentation of user_environment 1.0.1 Download user_environment 1.0.1 archive
1.0.0 Dec 4, 2017 Go to the documentation of user_environment 1.0.0 Download user_environment 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
16
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.1 <2.0.0