validate 1.7.0

  • Installing
  • Versions
  • 89


Lightweight library for validating function arguments in Dart.

This library is mainly a port of Apaches org.apache.commons.lang3.Validate class

Validation is necessary on most public-facing APIs. Parameter validation on non-public methods is not as important - it is often desirable to have validation occur only once, at the public 'entry point' - but if you can live with the potential performance hit, I recommend to validate parameters everywhere, as it makes code maintenance and refactoring a bit easier.

For further documentation please refere to the Unit-Tests.


  • 1.4.0 - Instance check added
  • 1.3.0 - Validate.isUUID added
  • 1.2.7 - Removed debug info from URIBuilder
  • 1.2.4 - Runs with Dart 1.1 + IntelliJ 13
  • 1.2.0 - isKeyInMap check added
  • 1.1.0 - isJson check added
  • 1.0.5 - Changed GitHub-Repository to dart-validate
  • 1.0.4 - Replaced NullPointerException with ArgumentError - makes more sense

You can see further changes on the CHANGELOG!


Copyright 2018 Michael Mitterer, IT-Consulting and Development Limited,
Austrian Branch

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

Unless required by applicable law or agreed to in writing, 
software distributed under the License is distributed on an 
either express or implied. See the License for the specific language 
governing permissions and limitations under the License.

If this plugin is helpful for you - please (Circle) me.

Change Log for validate

This class assists in validating method arguments

v1.7 - 2018-08-21


  • Support for GMAIL infinite mailboxes (PATTERN_EMAIL) changed. Closes #3 4af87cb

v1.5.4 - 2017-01-31


v1.5.3 - 2016-11-16


v1.5.2 - 2016-07-14


  • isKeyInMap shows Map as JSON-Structure 471c4e2

v1.5.1 - 2015-12-08


v1.5.0 - 2015-12-08


  • Changed to 'test', improved password-pattern 13e0926


This was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  validate: ^1.7.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:validate/validate.dart';
Version Uploaded Documentation Archive
1.7.0 Aug 21, 2018 Go to the documentation of validate 1.7.0 Download validate 1.7.0 archive
1.6.1 Aug 14, 2018 Go to the documentation of validate 1.6.1 Download validate 1.6.1 archive
1.6.0 Dec 13, 2017 Go to the documentation of validate 1.6.0 Download validate 1.6.0 archive
1.5.4 Jan 31, 2017 Go to the documentation of validate 1.5.4 Download validate 1.5.4 archive
1.5.3 Nov 16, 2016 Go to the documentation of validate 1.5.3 Download validate 1.5.3 archive
1.5.2 Jul 14, 2016 Go to the documentation of validate 1.5.2 Download validate 1.5.2 archive
1.5.1 Dec 8, 2015 Go to the documentation of validate 1.5.1 Download validate 1.5.1 archive
1.5.0 Dec 8, 2015 Go to the documentation of validate 1.5.0 Download validate 1.5.0 archive
1.4.2 Dec 19, 2014 Go to the documentation of validate 1.4.2 Download validate 1.4.2 archive
1.4.1 Dec 19, 2014 Go to the documentation of validate 1.4.1 Download validate 1.4.1 archive

All 26 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:validate/validate.dart.

Health suggestions

Fix lib/src/utils.dart. (-0.50 points)

Analysis of lib/src/utils.dart reported 1 hint:

line 23 col 7: Name types using UpperCamelCase.

Format lib/expect.dart.

Run dartfmt to format lib/expect.dart.

Format lib/src/errors.dart.

Run dartfmt to format lib/src/errors.dart.

Format lib/validate.dart.

Run dartfmt to format lib/validate.dart.

Maintenance issues and suggestions

Use analysis_options.yaml. (-10 points)

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use validate.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
build_runner any
build_test any
build_web_compilers any
console_log_handler ^1.0.0
grinder any
test any