validate 1.6.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 48

Validate #

Lightweight library for validating function arguments in Dart.

This library is mainly a port of Apaches org.apache.commons.lang3.Validate class

Validation is necessary on most public-facing APIs. Parameter validation on non-public methods is not as important - it is often desirable to have validation occur only once, at the public 'entry point' - but if you can live with the potential performance hit, I recommend to validate parameters everywhere, as it makes code maintenance and refactoring a bit easier.

For further documentation please refere to the Unit-Tests.

History #

  • 1.4.0 - Instance check added
  • 1.3.0 - Validate.isUUID added
  • 1.2.7 - Removed debug info from URIBuilder
  • 1.2.4 - Runs with Dart 1.1 + IntelliJ 13
  • 1.2.0 - isKeyInMap check added
  • 1.1.0 - isJson check added
  • 1.0.5 - Changed GitHub-Repository to dart-validate
  • 1.0.4 - Replaced NullPointerException with ArgumentError - makes more sense

You can see further changes on the CHANGELOG!

License #

Copyright 2017 Michael Mitterer, IT-Consulting and Development Limited,
Austrian Branch

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, 
software distributed under the License is distributed on an 
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, 
either express or implied. See the License for the specific language 
governing permissions and limitations under the License.

If this plugin is helpful for you - please (Circle) me.

Change Log for validate #

This class assists in validating method arguments

v1.5.4 - 2017-01-31

Docs #

v1.5.3 - 2016-11-16

Docs #

v1.5.2 - 2016-07-14

Docs #

  • isKeyInMap shows Map as JSON-Structure 471c4e2

v1.5.1 - 2015-12-08

Docs #

v1.5.0 - 2015-12-08

Feature #

  • Changed to 'test', improved password-pattern 13e0926

Docs #

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  validate: ^1.6.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:validate/validate.dart';
  
Version Uploaded Documentation Archive
1.7.0 Aug 21, 2018 Go to the documentation of validate 1.7.0 Download validate 1.7.0 archive
1.6.1 Aug 14, 2018 Go to the documentation of validate 1.6.1 Download validate 1.6.1 archive
1.6.0 Dec 13, 2017 Go to the documentation of validate 1.6.0 Download validate 1.6.0 archive
1.5.4 Jan 31, 2017 Go to the documentation of validate 1.5.4 Download validate 1.5.4 archive
1.5.3 Nov 16, 2016 Go to the documentation of validate 1.5.3 Download validate 1.5.3 archive
1.5.2 Jul 14, 2016 Go to the documentation of validate 1.5.2 Download validate 1.5.2 archive
1.5.1 Dec 8, 2015 Go to the documentation of validate 1.5.1 Download validate 1.5.1 archive
1.5.0 Dec 8, 2015 Go to the documentation of validate 1.5.0 Download validate 1.5.0 archive
1.4.2 Dec 19, 2014 Go to the documentation of validate 1.4.2 Download validate 1.4.2 archive
1.4.1 Dec 19, 2014 Go to the documentation of validate 1.4.1 Download validate 1.4.1 archive

All 26 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Running dartdoc failed with the following output:


Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0