vanilla 0.0.2

  • Installing
  • Versions
  • 50


Vanilla is a static blog generator written in Dart.

Vanilla is working in progress.


To install Vanilla:

$ pub global activate vanilla
$ vanilla help

If you encounter an error saying "command not found", make sure you have set your PATH correctly.





  • Create project with Stagehand.
  • Add some test code.

1. Depend on it

Add this to your package's pubspec.yaml file:

  vanilla: "^0.0.2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.2 Dec 12, 2017 Go to the documentation of vanilla 0.0.2 Download vanilla 0.0.2 archive
0.0.1 Dec 12, 2017 Go to the documentation of vanilla 0.0.1 Download vanilla 0.0.1 archive


We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in libraries.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use vanilla.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
test ^0.12.0