vanilla 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Vanilla

Vanilla is a static blog generator written in Dart.

Vanilla is working in progress.

Installation

To install Vanilla:

$ pub global activate vanilla
$ vanilla help

If you encounter an error saying "command not found", make sure you have set your PATH correctly.

License

MIT.

Changelog

0.0.1

  • Create project with Stagehand.
  • Add some test code.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate vanilla

2. Use it

The package has the following executables:


$ vanilla
Version Uploaded Documentation Archive
0.0.2 Dec 12, 2017 Go to the documentation of vanilla 0.0.2 Download vanilla 0.0.2 archive
0.0.1 Dec 12, 2017 Go to the documentation of vanilla 0.0.1 Download vanilla 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0