venosyd_common_validators 1.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

Venosyd Commom Validators

The Opensyd reusability approach for validators in Dart. Based on
Verbal Expressions.

Sample

  • validateEmail
var email = 'dude@email.com';
if (validadeEmail(email) {
    register(email);
}
  • validadeFutureDate

Used when you want to someone choose a date after today.

var date = new DateTime('2099', '11', '21');
if (validadeFutureDate(date) {
    someCode(date);
}
  • validateText / validateTextWithLimit

Used when you want to the user enters only characters used
in common dissertative or descritive texts.

var text = '''
    Lorem ipsum dolor sit amet, consectetur adipiscing elit. 
    In molestie bibendum gravida. Sed egestas venenatis ex, 
    vitae malesuada nibh consectetur nec. Integer posuere 
    pharetra justo, et egestas tellus imperdiet sed. Proin 
    eu augue molestie, egestas libero sed, tempus sapien. 
''';

if (validateText(text) {
    sendToBlog(text);
}
  • validateName / validateNameWithSpace

Validate common used chars for names, in Western method (needs upgrade).

var name = 'Roberto Santos Carlos Almeidinha';
if (validateNameWithSpace(name) {
    register(name);
}
  • validateAddress
var address = 'Priest Namegon St, 992 - Simula, DE';
if (validateAddress(address) {
    sendPackageTo(address);
}
  • validatePhone
var phone = '+42 11 99299-2299';
if (validatePhone(phone) {
    call(phone);
}

venosyd ©2016

Changelog

1.0.0

  • Initial version

example/venosyd_common_validators_example.dart

/**
 * @author sergio lisan
 *
 *  see LICENSE
 *
 *  validators sample
 *
 */

main() {

}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  venosyd_common_validators: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:venosyd_common_validators/venosyd_common_validators.dart';
  
Version Uploaded Documentation Archive
1.0.2 Feb 17, 2017 Go to the documentation of venosyd_common_validators 1.0.2 Download venosyd_common_validators 1.0.2 archive
1.0.1 Dec 16, 2016 Go to the documentation of venosyd_common_validators 1.0.1 Download venosyd_common_validators 1.0.1 archive
1.0.0 Dec 16, 2016 Go to the documentation of venosyd_common_validators 1.0.0 Download venosyd_common_validators 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0