venosyd_shelf_addons 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

venosyd_shelf_addons

Addons to Venosyd Shelf-like servers. These addons are:

- corsMiddleWare for CORS treatment
- jsonHandler, makeResponse, dartsonListToJson to treat data convertion

Usage

A simple usage example:

import 'package:venosyd_shelf_addons/venosyd_shelf_addons.dart';

main() {
  ..
  
  Middleware mw = logRequests();
  Pipeline pl = new Pipeline();
  pl = pl.addMiddleware(corsMiddleWare).addMiddleware(mw);
  
  ...
}

Changelog

1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  venosyd_shelf_addons: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:venosyd_shelf_addons/venosyd_shelf_addons.dart';
  
Version Uploaded Documentation Archive
1.0.0 Dec 15, 2016 Go to the documentation of venosyd_shelf_addons 1.0.0 Download venosyd_shelf_addons 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0