vexflow_stub 0.1.0-alpha.4

  • Installing
  • Versions
  • 0

VexFlow Stub #

Purpose of this library #

The purpose of this library is to provide a usable Dart interop for the VexFlow library, a library for rendering musical notation in HTML 5

Licensing #

This software is licensed using the MIT License. For more info, check LICENSE.

Credits #

Credit goes to 0xFE, for the original VexFlow lib, and to Google for the Dart language

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  vexflow_stub: ^0.1.0-alpha.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:vexflow_stub/vexflow_stub.dart';
Version Uploaded Documentation Archive
0.1.0-alpha.4 Nov 17, 2016 Go to the documentation of vexflow_stub 0.1.0-alpha.4 Download vexflow_stub 0.1.0-alpha.4 archive
0.1.0-alpha.3 Nov 17, 2016 Go to the documentation of vexflow_stub 0.1.0-alpha.3 Download vexflow_stub 0.1.0-alpha.3 archive
0.1.0-alpha.2 Nov 17, 2016 Go to the documentation of vexflow_stub 0.1.0-alpha.2 Download vexflow_stub 0.1.0-alpha.2 archive
0.1.0-alpha.1 Nov 17, 2016 Go to the documentation of vexflow_stub 0.1.0-alpha.1 Download vexflow_stub 0.1.0-alpha.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0