vizzie_dom 0.0.3-dev

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 47

VizDOM

Fluent data driven documents based selection and data-join API for HTML DOM

TODO

Basic

  • [ ] Bound data must be separate for each group
  • [ ] insertBound in BoundSelection
  • [ ] Lower
  • [ ] Raise
  • [ ] forEach
  • [ ] filter

SVG

  • [ ] svg
  • [ ] Line
  • [ ] Group

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vizzie_dom: "^0.0.3-dev"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:vizzie_dom/vizzie_dom.dart';
  
Version Uploaded Documentation Archive
0.0.3-dev Aug 26, 2017 Go to the documentation of vizzie_dom 0.0.3-dev Download vizzie_dom 0.0.3-dev archive
0.0.2-dev Aug 26, 2017 Go to the documentation of vizzie_dom 0.0.2-dev Download vizzie_dom 0.0.2-dev archive
0.0.1-dev Aug 26, 2017 Go to the documentation of vizzie_dom 0.0.1-dev Download vizzie_dom 0.0.1-dev archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
88 / 100
Overall score:
Weighted score of the above. [more]
47
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:vizzie_dom/vizzie_dom.dart with components: html.

Suggestions

  • Homepage does not exists.

    We were unable to access http://grizzly-dart.github.io at the time of the analysis.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 8 hints.

    Run dartfmt to format lib/src/axis/axis.dart.

    Run dartfmt to format lib/src/selection/bound.dart.

    Similar analysis of the following files failed:

    • lib/src/selection/sel.dart (hint)
    • lib/src/selection/selection.dart (hint)
    • lib/src/svg/svg.dart (hint)
    • lib/src/transition/transition.dart (hint)
    • lib/vizzie_dom.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use vizzie_dom.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
browser ^0.10.0
dart_to_js_script_rewriter ^1.0.1