A client for the Dart VM service.
VMScriptRef, which return a
VMSourceReportfor the target isolate or just the target script respectively.
VMScriptToken.offset is deprecated. This never returned the documented value
in the first place, and in practice determining that value isn't possible from
the information available in the token.
VMScript.getSpan() now return spans with the
correct line, column, and offset numbers.
new VMServiceClient() and
VMServiceClient.withoutJson() now take a
StreamChannel rather than a
Breaking change: the static asynchronous factory
VMServiceClient.connect() is now a synchronous constructor,
VMIsolate.pauseEventnow returns an instance of
VMNoneEventbefore the isolate is runnable.
VMIsolateRef.onExtensionEvent, which emits events posted by VM service
VMIsolateRef.selectExtensionEvents(), which selects events with specific
kinds posted by VM service extensions using
VMIsolateRef.onExtensionAdded, which emits an event when a VM service
extension registers a new RPC.
VMIsolateRef.waitForExtension(), which returns when a given extension
RPC is available.
VMIsolateRef.invokeExtension(), which invokes VM service extension RPCs
VMIsolate.extensionRpcs, which returns the extension RPCs registered in
a given isolate.
VMPauseEvent.timewould always be reported as
Add this to your package's pubspec.yaml file:
dependencies: vm_service_client: ^0.2.2+3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.2.6||Jul 23, 2018|
|0.2.5+1||Jul 20, 2018|
|0.2.5||Jul 12, 2018|
|0.2.4+3||May 30, 2018|
|0.2.4+1||Feb 1, 2018|
|0.2.4||Jan 16, 2018|
|0.2.3||Jan 4, 2017|
|0.2.2+4||Nov 18, 2016|
|0.2.2+3||Nov 17, 2016|
|0.2.2+2||Jun 22, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.16.0 <2.0.0|