vm_service_client 0.2.2+3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 47

A client for the Dart VM service.

0.2.2+3

  • Fix strong-mode errors and warnings.

0.2.2+2

  • Narrow the dependency on source_span.

0.2.2+1

  • Fix some documentation comments.

0.2.2

  • Add getSourceReport to VMIsolateRef and VMScriptRef, which return a VMSourceReport for the target isolate or just the target script respectively.

0.2.1

  • VMScriptToken.offset is deprecated. This never returned the documented value in the first place, and in practice determining that value isn't possible from the information available in the token.

  • VMScript.getLocation() and VMScript.getSpan() now return spans with the correct line, column, and offset numbers.

0.2.0

  • Breaking change: new VMServiceClient() and new VMServiceClient.withoutJson() now take a StreamChannel rather than a Stream/Sink pair.

  • Breaking change: the static asynchronous factory VMServiceClient.connect() is now a synchronous constructor, new VMServiceClient.connect().

0.1.3

  • On VM service versions 3.4 and greater, VMIsolate.pauseEvent now returns an instance of VMNoneEvent before the isolate is runnable.

0.1.2+1

  • Drop the dependency on the crypto package.

0.1.2

  • Add VMIsolateRef.onExtensionEvent, which emits events posted by VM service extensions using postEvent in dart:developer.

  • Add VMIsolateRef.selectExtensionEvents(), which selects events with specific kinds posted by VM service extensions using postEvent in dart:developer.

  • Add VMIsolateRef.onExtensionAdded, which emits an event when a VM service extension registers a new RPC.

  • Add VMIsolateRef.waitForExtension(), which returns when a given extension RPC is available.

  • Add VMIsolateRef.invokeExtension(), which invokes VM service extension RPCs registered using registerExtension in dart:developer.

  • Add VMIsolate.extensionRpcs, which returns the extension RPCs registered in a given isolate.

0.1.1+1

  • Fix a bug where VMPauseEvent.time would always be reported as null or crash.

0.1.1

  • Fix support for VM service protocol 1.0 events.

0.1.0

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vm_service_client: ^0.2.2+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:vm_service_client/vm_service_client.dart';
  
Version Uploaded Documentation Archive
0.2.6 Jul 23, 2018 Go to the documentation of vm_service_client 0.2.6 Download vm_service_client 0.2.6 archive
0.2.5+1 Jul 20, 2018 Go to the documentation of vm_service_client 0.2.5+1 Download vm_service_client 0.2.5+1 archive
0.2.5 Jul 12, 2018 Go to the documentation of vm_service_client 0.2.5 Download vm_service_client 0.2.5 archive
0.2.4+3 May 30, 2018 Go to the documentation of vm_service_client 0.2.4+3 Download vm_service_client 0.2.4+3 archive
0.2.4+1 Feb 1, 2018 Go to the documentation of vm_service_client 0.2.4+1 Download vm_service_client 0.2.4+1 archive
0.2.4 Jan 16, 2018 Go to the documentation of vm_service_client 0.2.4 Download vm_service_client 0.2.4 archive
0.2.3 Jan 4, 2017 Go to the documentation of vm_service_client 0.2.3 Download vm_service_client 0.2.3 archive
0.2.2+4 Nov 18, 2016 Go to the documentation of vm_service_client 0.2.2+4 Download vm_service_client 0.2.2+4 archive
0.2.2+3 Nov 17, 2016 Go to the documentation of vm_service_client 0.2.2+3 Download vm_service_client 0.2.2+3 archive
0.2.2+2 Jun 22, 2016 Go to the documentation of vm_service_client 0.2.2+2 Download vm_service_client 0.2.2+2 archive

All 19 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.16.0 <2.0.0