vscode 1.0.0

  • README.md
  • Installing
  • Versions
  • 30

dart_vscode

Dart bindings for the VSCode API.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vscode: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:vscode/vscode.dart';
  
Version Uploaded Documentation Archive
1.0.0 Dec 18, 2016 Go to the documentation of vscode 1.0.0 Download vscode 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: web, other

Primary library: package:vscode/vscode.dart with components: js.

Health suggestions

Format lib/vscode.dart.

Run dartfmt to format lib/vscode.dart.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-96.16 points)

The package was released 102 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use vscode.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
js ^0.6.1 0.6.1+1