vue2 0.3.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 13

VueDart

VueDart lets you create Vue web apps using Dart.

NOTICE: This will be the last VueDart release under the vue2 package name. From 0.4 onward, the vue package name will be used instead. The VueDart CLI will be able to help with the conversion.

Website and documentation

https://refi64.com/vuedart

Status

What works:

  • App and component definitions.
  • Templates.
  • Data.
  • Properties.
  • Computed data.
  • Methods.
  • Refs.
  • Lifecycle callbacks.
  • Mixins.
  • vue-router.
  • Scoped styles.

What doesn't work:

  • Render functions (or at least, they don't work well).
  • Some of the instance properties.
  • Server-side rendering.
  • Hardcoded support for the Vuex plugin.
  • Generic plugin support (this is going to take a while though).

Based on the official Vue logo. I basically just changed the color.

0.3.2

  • Fix #13: internal symbols were duplicated when using part with component files.
  • Merged #12: fixed typos in documentation.
  • Merged #16: check window.Vue to make sure it's been defined.

0.3.1

  • Upgrade scopify to 0.2.0.
  • BREAKING CHANGE Due to the above upgrade, scoped styles no longer "bleed" into child elements. This behavior can still be manually re-enabled via the bleeds option to the style element. (AFAIK no one actually really used this, so it's not really a big change.)

0.3.0

  • BREAKING CHANGE Require explicit declaration of entry points.
  • BREAKING CHANGE The VueComponent annotation now requires the name to be in a named argument (e.g. @VueComponent(name: 'foo'), instead of @VueComponent('foo')). This was necessary to support unnamed components.
  • Added the VueDart CLI.
  • Proper error messages.
  • Add VueMaterial 0.7 support.
  • Add vue-router support.
  • Avoid needlessly rewriting HTML source files by switching from html package's DOM manipulation to using Dart's refactoring libraries.
  • Change all vue.js script tags to vue.min.js when in release mode, not just unpkg ones.
  • Implement support for mixins (for components only for now).
  • Implement scoped styles.
  • Implement watchers.
  • Add support for more instance methods: $data, $props, $el, $options, $parent, $root, $on, $once, $off, $emit, $nextTick, $forceUpdate, and $destroy.
  • Add VueConfig and VueConfig.ignoredElements.

0.2.0

  • Remove need for explicit initialize transformer usage.
  • Upgrade initialize dependency for strong mode/DDC support.

0.1.0

  • Initial.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vue2: ^0.3.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:vue2/plugins/vue_router.dart';
import 'package:vue2/plugins/vuematerial.dart';
import 'package:vue2/transformer.dart';
import 'package:vue2/transformers/html_transformer.dart';
import 'package:vue2/transformers/initialize_transformer.dart';
import 'package:vue2/transformers/vue_transformer.dart';
import 'package:vue2/vue.dart';
  
Version Uploaded Documentation Archive
0.3.2 Apr 27, 2018 Go to the documentation of vue2 0.3.2 Download vue2 0.3.2 archive
0.3.1 Dec 16, 2017 Go to the documentation of vue2 0.3.1 Download vue2 0.3.1 archive
0.3.0 Nov 20, 2017 Go to the documentation of vue2 0.3.0 Download vue2 0.3.0 archive
0.2.0 Sep 4, 2017 Go to the documentation of vue2 0.2.0 Download vue2 0.2.0 archive
0.1.0 Aug 29, 2017 Go to the documentation of vue2 0.1.0 Download vue2 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
13
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0