VueDart lets you create Vue web apps using Dart.
NOTICE: This will be the last VueDart release under the vue2 package name. From 0.4 onward, the vue package name will be used instead. The VueDart CLI will be able to help with the conversion.
What doesn't work:
Based on the official Vue logo. I basically just changed the color.
partwith component files.
window.Vueto make sure it's been defined.
VueComponentannotation now requires the name to be in a named argument (e.g.
@VueComponent(name: 'foo'), instead of
@VueComponent('foo')). This was necessary to support unnamed components.
vue.jsscript tags to
vue.min.jswhen in release mode, not just unpkg ones.
Add this to your package's pubspec.yaml file:
dependencies: vue2: ^0.3.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:vue2/plugins/vue_router.dart'; import 'package:vue2/plugins/vuematerial.dart'; import 'package:vue2/transformer.dart'; import 'package:vue2/transformers/html_transformer.dart'; import 'package:vue2/transformers/initialize_transformer.dart'; import 'package:vue2/transformers/vue_transformer.dart'; import 'package:vue2/vue.dart';
|0.3.2||Apr 27, 2018|
|0.3.1||Dec 16, 2017|
|0.3.0||Nov 20, 2017|
|0.2.0||Sep 4, 2017|
|0.1.0||Aug 29, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <2.0.0|