vy_date 0.3.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

vy_date

Simple utilities for managing dates and periods.

The Date class simply wraps the DateTime one. But I think it is easier to manage and to understand the logic of the program this way. license.

Usage

A simple usage example:

import 'package:vy_date/vy_date.dart';

main() {
  Date date = new Date.now();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.3.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vy_date: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:vy_date/vy_date.dart';
  
Version Uploaded Documentation Archive
0.3.0 Jul 21, 2018 Go to the documentation of vy_date 0.3.0 Download vy_date 0.3.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.69.1 <2.0.0