wamp2 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 5

dart-wamp2

An implementation of the WAMP protocol for Dart.

WAMP is an open WebSocket subprotocol that provides two asynchronous messaging patterns: RPC and PubSub. WAMP is easy to use, simple to implement and based on modern Web standards: WebSocket, JSON and URIs.

This is a port of WAMP v1 forked from https://github.com/gmosx/dart-wamp

Homepage

https://github.com/ohyo-io/dart-wamp2

Example

Have a look at the included example that implements a simple chat room.

Notes to Contributors

If you'd like to contribute back to the project, you can fork this repository and send us a pull request, when it is ready.

If you are new to Git or GitHub, please read this guide first.

WAMP and the logo are trademarks of Tavendo GmbH. All other trademarks are those of their respective companies.

Changelog

0.1.0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wamp2: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wamp2/wamp.dart';
import 'package:wamp2/wamp_client.dart';
import 'package:wamp2/wamp_server.dart';
  
Version Uploaded Documentation Archive
0.1.0 May 31, 2018 Go to the documentation of wamp2 0.1.0 Download wamp2 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
10
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
5
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.1.2 <2.0.0