wasm_interop 1.0.0-dev.0.0

  • README.md
  • Installing
  • Versions
  • 43

WebAssembly JS API Bindings for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wasm_interop: ^1.0.0-dev.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wasm_interop/wasm_interop.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev.0.0 Jul 14, 2018 Go to the documentation of wasm_interop 1.0.0-dev.0.0 Download wasm_interop 1.0.0-dev.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
45
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: web, other

Primary library: package:wasm_interop/wasm_interop.dart with components: js.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use wasm_interop.dart.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68 <3.0.0
js ^0.6.1 0.6.1+1
meta ^1.1.5 1.1.6
Dev dependencies
build_node_compilers ^0.1.8
build_runner ^0.9.1
build_test ^0.10.3
build_web_compilers ^0.4.0
test ^1.2.0