weather_icons_flutter 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 26

weather_icons_flutter #

Weather icons wrapper for Flutter.io

Dependency #

In the dependencies: section of your pubspec.yaml, add the following line:

  weather_icons_flutter: ^1.0.0

Usage #

import 'package:weather_icons_flutter/weather_icons_flutter.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return new IconButton(
      // Use the WeatherIcons class for the IconData
      icon: new Icon(WeatherIcons.stars),
      onPressed: () { print("Pressed"); }
     );
  }
}

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  weather_icons_flutter: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:weather_icons_flutter/weather_icons_flutter.dart';
  
Version Uploaded Documentation Archive
1.0.2 Jan 18, 2018 Go to the documentation of weather_icons_flutter 1.0.2 Download weather_icons_flutter 1.0.2 archive
1.0.1 Jan 18, 2018 Go to the documentation of weather_icons_flutter 1.0.1 Download weather_icons_flutter 1.0.1 archive
1.0.0 Jan 17, 2018 Go to the documentation of weather_icons_flutter 1.0.0 Download weather_icons_flutter 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
26
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.