web_api 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

web_api

A library for creating Restful apis

Usage

The model:

@Serializable() //Each class which is returned by a controller or is a parameter of a controller must have the @Serializable() annotation
class Member{

  int id;
  String email;
  String name;

}

The controller:

class MemberController extends Controller{

  @HttpPost("/members")
  @MemberLinkProvider()
  Member addMember(@Body() Member newMember){
    if(DatabaseDummy.members.length==0){
      newMember.id=0;
    }
    else{
      newMember.id=DatabaseDummy.members.last.id+1;
    }
    DatabaseDummy.members.add(newMember);
    return newMember;
  }

  @HttpGet("/members")
  List<Member> getMembers(){
    return DatabaseDummy.members;
  }

}

Your startup method

HttpServer server = await HttpServer.bind(InternetAddress.LOOPBACK_IP_V4,8080);
RequestMapper requestMapper = new RequestMapper((type){
  if(type == MemberController){
    return new MemberController();
  }
});
requestMapper.addController(MemberController);
requestMapper.handle(server);

For more details look at the example folder.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/main.dart

import 'web_api_example.dart';

void main(){
  new App();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  web_api: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:web_api/web_api.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jul 5, 2016 Go to the documentation of web_api 0.0.1 Download web_api 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0