webapper 0.0.1

  • Installing
  • Versions
  • 0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  webapper: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:webapper/webapper.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 2, 2016 Go to the documentation of webapper 0.0.1 Download webapper 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Fix lib/src/Interface.dart. (-25 points)

Analysis of lib/src/Interface.dart failed with 1 error:

line 15 col 16: Undefined name 'Path'.

Fix lib/webapper.dart. (-25 points)

Analysis of lib/webapper.dart failed with 1 error:

line 5 col 8: Target of URI doesn't exist: 'src/path.dart'.

Fix lib/src/WebApper.dart. (-0.50 points)

Analysis of lib/src/WebApper.dart reported 1 hint:

line 4 col 47: 'LOOPBACK_IP_V4' is deprecated and shouldn't be used.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/Mime.dart (Run dartfmt to format lib/src/Mime.dart.)
  • lib/src/Path.dart (Run dartfmt to format lib/src/Path.dart.)
  • lib/src/Route.dart (Run dartfmt to format lib/src/Route.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/webapper.dart: Target of URI doesn't exist: 'src/path.dart'.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain README.md. (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Homepage does not exists. (-20 points)

We were unable to access https://github.com/btwael/webapper at the time of the analysis.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use webapper.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.