webapper 0.0.1

  • Installing
  • Versions
  • 17

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  webapper: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:webapper/webapper.dart';
Version Uploaded Documentation Archive
0.0.1 Apr 2, 2016 Go to the documentation of webapper 0.0.1 Download webapper 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8


Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/webapper.dart: Target of URI doesn't exist: 'src/path.dart'.

Issues and suggestions

Fix lib/src/Interface.dart.

Analysis of lib/src/Interface.dart failed with 1 error:

line 15 col 16: Undefined name 'Path'.

Fix lib/webapper.dart.

Analysis of lib/webapper.dart failed with 1 error:

line 5 col 8: Target of URI doesn't exist: 'src/path.dart'.

Fix platform conflicts.

Error(s) prevent platform classification:

Error(s) in lib/webapper.dart: Target of URI doesn't exist: 'src/path.dart'.

Running dartdoc failed.

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Homepage does not exists.

We were unable to access https://github.com/btwael/webapper at the time of the analysis.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Maintain README.md.

Readme should inform others about your project, what it does, and how they can use it.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use webapper.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/Mime.dart (Run dartfmt to format lib/src/Mime.dart.)
  • lib/src/Path.dart (Run dartfmt to format lib/src/Path.dart.)
  • lib/src/Route.dart (Run dartfmt to format lib/src/Route.dart.)
  • lib/src/WebApper.dart (1 hint)