where 4.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 62

Where.dart

Runtime Release License Coverage Build

Find the instances of an executable in the system path, implemented in Dart.

Resources

License

Where.dart is distributed under the MIT License.

Changelog

Version 4.0.0

  • Breaking change: starting to use and support the Dart 2 SDK.
  • Added a user guide based on MkDocs.
  • Added the FinderException class.
  • Updated the package dependencies.

Version 3.0.0

  • Added support for Node.js platform.
  • Breaking change: removed the FileStat.stat() method.
  • Breaking change: renamed the FileStat class to FileStats.
  • Added the fileSystem, platform and processManager constants.
  • Added the getFileStats() function.
  • Added the arguments and exitCode properties.

Version 2.2.0

  • Updated the package dependencies.

Version 2.1.1

  • Fixed a bug: the CLI script doesn't run when using the pub global run command.

Version 2.1.0

  • Changed the signature of the FileStat class constructor.

Version 2.0.0

  • Breaking change: changed the signature of the Finder class constructor.
  • Breaking change: removed the Application class.
  • Breaking change: the version property is now private.
  • Converted the constructor of the FileStat class to a constant one.
  • Updated the package dependencies.

Version 1.1.0

Version 1.0.0

  • Added a command line interface.
  • Added new unit tests.

Version 0.1.0

  • Initial release.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  where: "^4.0.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:where/where.dart';
        
Version Uploaded Documentation Archive
4.0.0 Mar 5, 2018 Go to the documentation of where 4.0.0 Download where 4.0.0 archive
3.0.0 Dec 6, 2017 Go to the documentation of where 3.0.0 Download where 3.0.0 archive
2.2.0 Nov 3, 2017 Go to the documentation of where 2.2.0 Download where 2.2.0 archive
2.1.1 Sep 15, 2017 Go to the documentation of where 2.1.1 Download where 2.1.1 archive
2.1.0 Sep 11, 2017 Go to the documentation of where 2.1.0 Download where 2.1.0 archive
2.0.0 Sep 11, 2017 Go to the documentation of where 2.0.0 Download where 2.0.0 archive
1.1.0 Sep 8, 2017 Go to the documentation of where 1.1.0 Download where 1.1.0 archive
1.0.0 Aug 11, 2017 Go to the documentation of where 1.0.0 Download where 1.0.0 archive
0.1.0 Aug 9, 2017 Go to the documentation of where 0.1.0 Download where 0.1.0 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
25 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
62
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:where/where.dart with components: io.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 6 hints.

    Run dartfmt to format lib/src/core/file_stats.dart.

    Run dartfmt to format lib/src/file.dart.

    Similar analysis of the following files failed:

    • lib/src/file/finder.dart (hint)
    • lib/src/file/where.dart (hint)
    • lib/src/io/node.dart (hint)
    • lib/src/io/vm.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use where.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <2.0.0
args ^1.4.1 1.4.1
file ^2.3.7 2.3.7 4.0.0
nodejs_interop ^0.9.0 0.9.0
platform ^2.1.2 2.1.2
process ^2.0.7 2.0.9
yaml ^2.1.13 2.1.13
Transitive dependencies
async 2.0.6
barback 0.15.2+15
charcode 1.1.1
collection 1.14.9
http 0.11.3+16
http_parser 3.1.1
intl 0.15.4
js 0.6.1
meta 1.1.2
path 1.5.1
pool 1.3.4
quiver_hashcode 1.0.0
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
tuple 1.0.1
typed_data 1.1.5
Dev dependencies
coverage ^0.10.0
grinder ^0.8.1
node_preamble ^1.4.0 1.4.0
test ^0.12.30