woo_commerce_api_dart 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

woocommerce_api

A dart package to interact with the WooCommerce API. It uses OAuth1.0a behind the scenes to generate the signature and URL string. It then makes calls and return the data back to the calling function.

Getting Started

  • Import the package

import 'package:woo_commerce_api_dart/woo_commerce_api.dart';

  • Initialize the SDK
WooCommerceAPI wcApi = new WooCommerceAPI(
    "http://www.mywoocommerce.com",
    "ck_...",
    "cs_..."
);
  • Use functions
List _products = new List();

wcApi.getAsync("products?page=2").then((val) {
    List parsedMap = val;
    setState(() {
    parsedMap.forEach((f){
        _products.add(f);
    });
    print(_products.length);
    });
});

[0.0.3] - 16/09/18

  • Auth token params added in POST requests

[0.0.2] - 30/08/18

  • Updated to support dart 2+ version

[0.0.1] - 30/08/18

  • Added getAsync and postAsync functions.

example/main.dart

import 'package:woo_commerce_api_dart/woo_commerce_api.dart';

void main() {
  final wcApi = WooCommerceAPI(
      "http://www.bookinthecity.com", "ck_xxxxxxxxx", "cs_xxxxxxxxx");

  wcApi.getAsync('products/categories').then((response) {
    print(response);
  });

  wcApi.postAsync('customers', {
    "email": 'john.doe@example.com',
    "first_name": 'John',
    "last_name": 'Doe',
    "username": 'john.doe',
    "password": 'xxxx'
  }).then((response) {
    print(response);
  });
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  woo_commerce_api_dart: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:woo_commerce_api_dart/woo_commerce_api.dart';
  
Version Uploaded Documentation Archive
0.0.3 Sep 15, 2018 Go to the documentation of woo_commerce_api_dart 0.0.3 Download woo_commerce_api_dart 0.0.3 archive
0.0.2 Aug 29, 2018 Go to the documentation of woo_commerce_api_dart 0.0.2 Download woo_commerce_api_dart 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
crypto ^2.0.6 2.0.6
flutter 0.0.0
http ^0.11.3+17 0.11.3+17 0.12.0
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
http_parser 3.1.3
meta 1.1.6
path 1.6.2
sky_engine 0.0.99
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test