wordpress_api 0.1.2+3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 83

WordPress API client for Dart (Flutter)

Description #

A WordPress API client for flutter with support for WooCommerce and custom namespaces.

Features #

  • Retrieve data from any endpoint.
  • Retrieve data from any namespace.

Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

wordpress_api: <latest_version>

Usage #

  • Import the package
import 'package:wordpress_api/wordpress_api';
  • Initialize WPAPI
  WordPressAPI api = WordPressAPI('site.com');
  • Retrieve data from an endpoint
  void fetchPosts() async {

    try {
          final res = await api.get('posts');
          print(res['data']);
    } catch (e) {
      throw Exception(e);
    }
  }

To Do #

  • Add authentication function
  • Add postAsync function

Contributions are welcome, report any issues here

[0.1.2+3]

  • Minor fixes

[0.1.2+2]

  • Added endpoint query handler

[0.1.2+1]

  • Added getAsyc exception

[0.1.2]

  • Fixed the error in JSON endpoint retrieval

[0.1.1+2]

  • Changed getAsync return raw json body
  • Changed example code url

[0.1.1+1]

  • Changed getAsync return data to a map.

[0.1.1]

  • Updated example and readme

[0.1.0]

  • Added an example

[0.0.2]

  • Updated documentation

[0.0.1]

  • Initial release.

example/README.md

WordPress API Example #

An example app that utilizes the WordPress API

Get the code here

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wordpress_api: ^0.1.2+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wordpress_api/wordpress_api.dart';
  
Version Uploaded Documentation Archive
0.1.2+3 Jan 22, 2019 Go to the documentation of wordpress_api 0.1.2+3 Download wordpress_api 0.1.2+3 archive
0.1.2+2 Jan 20, 2019 Go to the documentation of wordpress_api 0.1.2+2 Download wordpress_api 0.1.2+2 archive
0.1.2+1 Jan 7, 2019 Go to the documentation of wordpress_api 0.1.2+1 Download wordpress_api 0.1.2+1 archive
0.1.2 Jan 2, 2019 Go to the documentation of wordpress_api 0.1.2 Download wordpress_api 0.1.2 archive
0.1.1+2 Jan 1, 2019 Go to the documentation of wordpress_api 0.1.1+2 Download wordpress_api 0.1.1+2 archive
0.1.1+1 Jan 1, 2019 Go to the documentation of wordpress_api 0.1.1+1 Download wordpress_api 0.1.1+1 archive
0.1.1 Jan 1, 2019 Go to the documentation of wordpress_api 0.1.1 Download wordpress_api 0.1.1 archive
0.1.0 Jan 1, 2019 Go to the documentation of wordpress_api 0.1.0 Download wordpress_api 0.1.0 archive
0.0.2 Jan 1, 2019 Go to the documentation of wordpress_api 0.0.2 Download wordpress_api 0.0.2 archive
0.0.1 Dec 31, 2018 Go to the documentation of wordpress_api 0.0.1 Download wordpress_api 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
65
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
83
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
http ^0.12.0 0.12.0+1
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.4
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test