wsgrpc 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 38

wsgrpc #

A gRPC channel base on websocket.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wsgrpc: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wsgrpc/wsgrpc.dart';
  
Version Uploaded Documentation Archive
0.0.1 Aug 11, 2018 Go to the documentation of wsgrpc 0.0.1 Download wsgrpc 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13

Platforms

Detected platforms: Flutter, other

Primary library: package:wsgrpc/wsgrpc.dart with components: io.

Health suggestions

Fix lib/src/connection.dart. (-0.50 points)

Analysis of lib/src/connection.dart reported 1 hint:

line 63 col 7: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Fix lib/src/transport.dart. (-0.50 points)

Analysis of lib/src/transport.dart reported 1 hint:

line 150 col 50: 'OPEN' is deprecated and shouldn't be used.

Format lib/generated/wsgrpc.pb.dart.

Run dartfmt to format lib/generated/wsgrpc.pb.dart.

Format lib/generated/wsgrpc.pbenum.dart.

Run dartfmt to format lib/generated/wsgrpc.pbenum.dart.

Format lib/generated/wsgrpc.pbjson.dart.

Run dartfmt to format lib/generated/wsgrpc.pbjson.dart.

Maintenance issues and suggestions

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and wsgrpc.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <=2.1.0
grpc ^0.6.1 0.6.8+1 1.0.1
http2 ^0.1.8+2 0.1.9 1.0.0
protobuf ^0.9.1 0.9.1 0.13.3
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
fixnum 0.10.9
googleapis_auth 0.2.6
http 0.12.0+1
http_parser 3.1.3
meta 1.1.7
path 1.6.2
source_span 1.5.4
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test any