xframework 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 35

xframework

A library for Dart developers. It is awesome.

Usage

A simple usage example:

import 'package:xframework/xframework.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  xframework: "^0.0.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:xframework/xframework.dart';
        
Version Uploaded Documentation Archive
0.0.2 Feb 24, 2017 Go to the documentation of xframework 0.0.2 Download xframework 0.0.2 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
64 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
82 / 100
Overall score:
Weighted score of the above. [more]
35
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:xframework/xframework.dart with components: io.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 errors 4 hints.

    Strong-mode analysis of lib/src/app.dart failed with the following error:

    line: 4 col: 8
    Target of URI doesn't exist: '../../webreflect/api.dart'.

    Run dartfmt to format lib/src/component.dart.

    Similar analysis of the following files failed:

    • lib/src/container.dart (hint)
    • lib/src/widget.dart (hint)
  • Fix .analysis_options.

    We were unable to parse .analysis_options.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use xframework.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

  • Enable strong mode analysis.

    Strong mode helps you to detect bugs and potential issues earlier.Start your analysis_options.yaml file with the following:

    analyzer:
      strong-mode: true
    

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
webreflect >=0.0.2 <0.1.0 0.0.2
Dev dependencies
test >=0.12.0 <0.13.0