xhr_interceptor_facade 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

xhr_interceptor_facade

Use http-mocker in Dart tests.

Usage

A simple usage example:

main() {
  var xi = new XHRInterceptor();

  xi.matchAll([
    M('/some-route', {
      'response_field_1': 1,
      'response_field_2': 'aa',
      'response_field_3': true
    })
  ]);

  xi.intercept();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/xhr_interceptor_facade_example.dart

// Copyright (c) 2016, kulshekhar. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:xhr_interceptor_facade/xhr_interceptor_facade.dart';

main() {
  var xi = new XHRInterceptor();

  xi.matchAll([
    M('/some-route', {
      'response_field_1': 1,
      'response_field_2': 'aa',
      'response_field_3': true
    })
  ]);

  xi.intercept();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  xhr_interceptor_facade: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:xhr_interceptor_facade/xhr_interceptor_facade.dart';
  
Version Uploaded Documentation Archive
0.0.1 Nov 22, 2016 Go to the documentation of xhr_interceptor_facade 0.0.1 Download xhr_interceptor_facade 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0