xml_json_parser 1.0.0

  • README.md
  • Installing
  • Versions
  • new56


An XML to JSON Parser package.

This package helps to transform a XML strings to JSON.

This package depends of petitparser XML parser to peform the parsing of XML data.

See the main XmlJsonParser class for usage.

[1.0.0] - 06/22/2018

  • The JSON returned had wrong format. Now respeects the XML structure.

[0.0.3] - 06/22/2018

  • The transform() method now returns a Map<String, dynamic> object.

[0.0.2] - 06/22/2018

  • The _convertNode() method return node.text always node isn't a XmlElement.

[0.0.1] - 06/21/2018

  • Generate API documents

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  xml_json_parser: "^1.0.0"

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:xml_json_parser/xml_json_parser.dart';
Version Uploaded Documentation Archive
1.0.0 Jun 22, 2018 Go to the documentation of xml_json_parser 1.0.0 Download xml_json_parser 1.0.0 archive
0.0.3 Jun 22, 2018 Go to the documentation of xml_json_parser 0.0.3 Download xml_json_parser 0.0.3 archive
0.0.2 Jun 22, 2018 Go to the documentation of xml_json_parser 0.0.2 Download xml_json_parser 0.0.2 archive
0.0.1 Jun 22, 2018 Go to the documentation of xml_json_parser 0.0.1 Download xml_json_parser 0.0.1 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4


Describes how popular the package is relative to other packages. [more]
14 / 100
Code health derived from static analysis. [more]
96 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use xml_json_parser.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Run flutter format to format lib/xml_json_parser.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0<2.0.0
xml >=3.0.0 <4.0.0 3.0.0
Transitive dependencies
collection 1.14.10
matcher 0.12.3
path 1.6.0 1.6.1
petitparser 1.7.6
stack_trace 1.9.2
Dev dependencies