xml_json_parser 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

xml_json_parser

An XML to JSON Parser package.

This package helps to transform a XML strings to JSON.

This package depends of petitparser XML parser to peform the parsing of XML data.

See the main XmlJsonParser class for usage.

[1.0.0] - 06/22/2018

  • The JSON returned had wrong format. Now respeects the XML structure.

[0.0.3] - 06/22/2018

  • The transform() method now returns a Map<String, dynamic> object.

[0.0.2] - 06/22/2018

  • The _convertNode() method return node.text always node isn't a XmlElement.

[0.0.1] - 06/21/2018

  • Generate API documents

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  xml_json_parser: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:xml_json_parser/xml_json_parser.dart';
  
Version Uploaded Documentation Archive
1.0.0 Jun 22, 2018 Go to the documentation of xml_json_parser 1.0.0 Download xml_json_parser 1.0.0 archive
0.0.3 Jun 22, 2018 Go to the documentation of xml_json_parser 0.0.3 Download xml_json_parser 0.0.3 archive
0.0.2 Jun 22, 2018 Go to the documentation of xml_json_parser 0.0.2 Download xml_json_parser 0.0.2 archive
0.0.1 Jun 22, 2018 Go to the documentation of xml_json_parser 0.0.1 Download xml_json_parser 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0<2.0.0