xservice_kit 0.0.16

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

xservice_kit

A plutter plugin helps build scalable plugin

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1

  • TODO: Describe initial release.

example/README.md

xservice_kit_example

Demonstrates how to use the xservice_kit plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  xservice_kit: ^0.0.16

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:xservice_kit/xservice_kit.dart';
  
Version Uploaded Documentation Archive
0.0.16 Nov 26, 2018 Go to the documentation of xservice_kit 0.0.16 Download xservice_kit 0.0.16 archive
0.0.15 Nov 14, 2018 Go to the documentation of xservice_kit 0.0.15 Download xservice_kit 0.0.15 archive
0.0.14 Nov 14, 2018 Go to the documentation of xservice_kit 0.0.14 Download xservice_kit 0.0.14 archive
0.0.13 Oct 16, 2018 Go to the documentation of xservice_kit 0.0.13 Download xservice_kit 0.0.13 archive
0.0.12 Oct 16, 2018 Go to the documentation of xservice_kit 0.0.12 Download xservice_kit 0.0.12 archive
0.0.11 Oct 15, 2018 Go to the documentation of xservice_kit 0.0.11 Download xservice_kit 0.0.11 archive
0.0.1 Oct 15, 2018 Go to the documentation of xservice_kit 0.0.1 Download xservice_kit 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

32 out of 32 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Fix lib/foundation_ext/type_converter.dart. (-1.99 points)

Analysis of lib/foundation_ext/type_converter.dart reported 4 hints:

line 2 col 6: Name non-constant identifiers using lowerCamelCase.

line 19 col 8: Name non-constant identifiers using lowerCamelCase.

line 26 col 5: Name non-constant identifiers using lowerCamelCase.

line 42 col 8: Name non-constant identifiers using lowerCamelCase.

Fix lib/ServiceTemplate.dart. (-1.49 points)

Analysis of lib/ServiceTemplate.dart reported 3 hints:

line 6 col 17: Don't explicitly initialize variables to null.

line 7 col 16: Don't explicitly initialize variables to null.

line 15 col 19: Don't explicitly initialize variables to null.

Format lib/ServiceCallHandler.dart.

Run flutter format to format lib/ServiceCallHandler.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/ServiceGateway.dart (Run flutter format to format lib/ServiceGateway.dart.)
  • lib/foundation_ext/foundation_ext.dart (Run flutter format to format lib/foundation_ext/foundation_ext.dart.)
  • lib/xservice_kit.dart (Run flutter format to format lib/xservice_kit.dart.)

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.49.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8