yabwe 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 82

Wrap of MediumEditor

Basic usage

<head>
    ...
    <script src="//cdn.jsdelivr.net/npm/medium-editor@latest/dist/js/medium-editor.min.js"></script>
    <link rel="stylesheet" href="//cdn.jsdelivr.net/npm/medium-editor@latest/dist/css/medium-editor.min.css" type="text/css" media="screen" charset="utf-8">
    ...
</head>

<body>
    ...
    <div class="editable"></div>
    ...
</body>
final mediumEditor = new MediumEditor(element.querySelector('.editable'),
    options: new MediumEditorOptions(
        placeholder:
            new PlaceHolderOptions(text: 'Your note', hideOnClick: true)));

To set the content of the editor use setContent like that

mediumEditor.setContent("Edit me!");

And to get the content of the editor use getContent

final content = mediumEditor.getContent();

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  yabwe: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:yabwe/yabwe.dart';
  
Version Uploaded Documentation Archive
0.0.1 Feb 21, 2018 Go to the documentation of yabwe 0.0.1 Download yabwe 0.0.1 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
65 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
82
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:yabwe/yabwe.dart with components: html, js.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use yabwe.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
dart_browser_loader ^0.0.4 0.0.4
js ^0.6.1 0.6.1
Transitive dependencies
browser 0.10.0+3
Dev dependencies
test ^0.12.0