yamlicious 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

yamlicious

A library for writing yaml files

Usage

A simple usage example:

import 'package:yamlicious/yamlicious.dart';

main() {
  var yamlStr = toYamlString(yamlNode);
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.5

  • strong mode
  • quiver -> quiver_iterables

0.0.4

  • tidy dependencies

0.0.2

  • fix handling of doubles and quoting strings (thanks @rbellens)

0.0.1

  • Initial version, created by Stagehand

example/yamlicious.dart

// Copyright (c) 2015, Anders Holmgren. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library yamlicious.example;

import 'dart:io' show File;

import 'package:yaml/yaml.dart' show loadYaml;
import 'package:yamlicious/yamlicious.dart' show toYamlString;

main() {
  File file = new File("pubspec.yaml");
  print(toYamlString(loadYaml(file.readAsStringSync())));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  yamlicious: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:yamlicious/yamlicious.dart';
  
Version Uploaded Documentation Archive
0.0.5 Nov 12, 2016 Go to the documentation of yamlicious 0.0.5 Download yamlicious 0.0.5 archive
0.0.4 Jan 21, 2016 Go to the documentation of yamlicious 0.0.4 Download yamlicious 0.0.4 archive
0.0.3 Aug 20, 2015 Go to the documentation of yamlicious 0.0.3 Download yamlicious 0.0.3 archive
0.0.2 Aug 1, 2015 Go to the documentation of yamlicious 0.0.2 Download yamlicious 0.0.2 archive
0.0.1+2 Apr 19, 2015 Go to the documentation of yamlicious 0.0.1+2 Download yamlicious 0.0.1+2 archive
0.0.1+1 Apr 19, 2015 Go to the documentation of yamlicious 0.0.1+1 Download yamlicious 0.0.1+1 archive
0.0.1 Apr 19, 2015 Go to the documentation of yamlicious 0.0.1 Download yamlicious 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0