youtube_parser 0.9.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 44

Dart YouTube Parser

Usage

import "package:youtube_parser/youtube_parser.dart";

String foo = getIdFromUrl("https://www.youtube.com/watch?v=CBWlfU_na-2");
// returns "CBWlfU_na-2"

String bar = getIdFromUrl("https://www.notyoutube.com/watch?v=CBWlfU_na-2");
// returns null

License

This project is licensed under the MIT License - see the LICENSE file for details

0.9.2

  • Fix regex
  • Add tests
  • Bump up allowed SDK version

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  youtube_parser: "^0.9.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:youtube_parser/youtube_parser.dart';
        
Version Uploaded Documentation Archive
0.9.2 Oct 15, 2017 Go to the documentation of youtube_parser 0.9.2 Download youtube_parser 0.9.2 archive
0.9.1 Aug 20, 2017 Go to the documentation of youtube_parser 0.9.1 Download youtube_parser 0.9.1 archive
0.9.0 Aug 20, 2017 Go to the documentation of youtube_parser 0.9.0 Download youtube_parser 0.9.0 archive

Analysis

This feature is new.
We welcome feedback.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Dec 6, 2017
  • Dart: 2.0.0-dev.8.0
  • pana: 0.7.3+1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
3
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
78
Overall score:
Weighted score of the above. [more]
44

Platforms

Detected platforms: Flutter, server, web

All libraries agree

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

Dependencies

Package Constraint Resolved Available
Dev dependencies
test ^0.12.21