zengen 0.4.0

  • Installing
  • Versions
  • 60

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  zengen: "^0.4.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:zengen/zengen.dart';
        
Version Uploaded Documentation Archive
0.4.0 Nov 2, 2016 Go to the documentation of zengen 0.4.0 Download zengen 0.4.0 archive
0.3.2 Dec 22, 2015 failed Download zengen 0.3.2 archive
0.3.1 Dec 15, 2015 failed Download zengen 0.3.1 archive
0.3.0 Oct 8, 2015 failed Download zengen 0.3.0 archive
0.2.8 Dec 10, 2014 failed Download zengen 0.2.8 archive
0.2.7 Jun 22, 2014 failed Download zengen 0.2.7 archive
0.2.6 Jun 17, 2014 failed Download zengen 0.2.6 archive
0.2.5 Jun 16, 2014 failed Download zengen 0.2.5 archive
0.2.4 Jun 14, 2014 failed Download zengen 0.2.4 archive
0.2.3 Jun 12, 2014 failed Download zengen 0.2.3 archive

All 15 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
43 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40 / 100
Overall score:
Weighted score of the above. [more]
60
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:zengen/zengen.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use zengen.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0
collection ^1.0.0 1.14.9
quiver_hashcode ^1.0.0 1.0.0