zengen_generator 0.4.0

  • Installing
  • Versions
  • 15

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  zengen_generator: "^0.4.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:zengen_generator/zengen_generator.dart';
  
Version Uploaded Documentation Archive
0.4.0 Nov 2, 2016 Go to the documentation of zengen_generator 0.4.0 Download zengen_generator 0.4.0 archive

Analysis

We analyzed this package on Jun 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
33 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
24 / 100
Overall score:
Weighted score of the above. [more]
15
Learn more about scoring.

Platforms

Detected platforms: web, other

Primary library: package:zengen_generator/zengen_generator.dart with components: mirrors.

Suggestions

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 errors 3 hints.

    Strong-mode analysis of lib/zengen_generator.dart failed with the following error:

    line: 509 col: 11
    The argument type '(int) → TypeParameterType' can't be assigned to the parameter type '(dynamic) → DartType'.

    Strong-mode analysis of lib/src/util.dart gave the following hint:

    line: 114 col: 17
    'substitute3' is deprecated and shouldn't be used.

  • Package is getting outdated.

    The package was released 85 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use zengen_generator.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0
source_gen ^0.5.0 0.5.10+1 0.8.2
zengen 0.4.0 0.4.0
Transitive dependencies
analyzer 0.30.0+4 0.32.1
args 1.4.3
async 2.0.7
build 0.9.3 0.12.7
charcode 1.1.1
cli_util 0.1.3
collection 1.14.10
convert 2.0.1
crypto 2.0.5
csslib 0.14.4
dart_style 1.0.9+1 1.1.0
front_end 0.1.0-alpha.4.1 0.1.1
glob 1.1.6
html 0.13.3+1
isolate 1.1.0 2.0.1
kernel 0.3.0-alpha.1.1 0.3.1
logging 0.11.3+1
meta 1.1.5
package_config 1.0.3
path 1.6.1
plugin 0.2.0+2
quiver_hashcode 1.0.0
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
yaml 2.1.14
Dev dependencies
browser ^0.10.0
test ^0.12.0