zoomable_image 1.1.2

  • README.md
  • Example
  • Installing
  • Versions
  • 90

zoomable_image

A dart+flutter package for panning and zooming images by touch.

Getting Started

new ZoomableImage(new AssetImage('images/squirrel.jpg'), scale: 16.0)

That's all you need. See below and example/ for squirrels.

demo!

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:zoomable_image/zoomable_image.dart';

void main() {
  runApp(
    new MaterialApp(
      home: new Scaffold(
        body: new ZoomableImage(new AssetImage('images/squirrel.jpg'),
            scale: 16.0),
      ),
    ),
  );
}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  zoomable_image: "^1.1.2"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:zoomable_image/zoomable_image.dart';
        
Version Uploaded Documentation Archive
1.1.2 Nov 25, 2017 Go to the documentation of zoomable_image 1.1.2 Download zoomable_image 1.1.2 archive
1.1.1 Jul 13, 2017 Go to the documentation of zoomable_image 1.1.1 Download zoomable_image 1.1.1 archive
1.1.0 May 18, 2017 Go to the documentation of zoomable_image 1.1.0 Download zoomable_image 1.1.0 archive
1.0.5 May 15, 2017 Go to the documentation of zoomable_image 1.0.5 Download zoomable_image 1.0.5 archive
1.0.4 May 13, 2017 Go to the documentation of zoomable_image 1.0.4 Download zoomable_image 1.0.4 archive
1.0.3 May 11, 2017 Go to the documentation of zoomable_image 1.0.3 Download zoomable_image 1.0.3 archive
1.0.1 May 11, 2017 Go to the documentation of zoomable_image 1.0.1 Download zoomable_image 1.0.1 archive
1.0.0 May 11, 2017 Go to the documentation of zoomable_image 1.0.0 Download zoomable_image 1.0.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6
  • Flutter: 0.3.2

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
89 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
90
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/src/zoomable_image.dart gave the following hint:

    line: 6 col: 8
    Unused import: 'package:flutter/services.dart'.

    Run flutter format to format lib/zoomable_image.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.9
meta 1.1.2
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6