zwave is a Dart package for interacting with Z-Wave devices.
This Dart package uses the Open Z-Wave library to communicate with a compatible Z-Wave Controller and interact with Z-Wave devices.
This package provides
See the zwave library for more about how to interact with Z-Wave devices.
A Z-Wave Controller such as the Aeon Labs Aeotec Z-Wave Z-Stick, Gen5 (ZW090).
The Open Z-Wave library used by this Dart library to communicate with the Z-Wave controller. Tested with Open Z-Wave Library 1.4.256
Pair your Z-Wave controller with your Z-Wave devices, then install the Open Z-Wave library. Use the MinOZW example that is included in the Open Z-Wave library to ensure that the Open Z-Wave library is installed correctly and can communicate with your devices using your Z-Wave Controller.
Activate this zwave package using the pub global command.
pub global activate zwave
From your application directory (the application that references the zwave package) run the following command to build the native library
pub global run zwave:build_lib
pub global activate makes the Dart scripts in the zwave/bin directory runnable from the command line. pub global run zwave:build_lib runs the zwave/bin/build_lib.dart program which in turn calls the build_lib script to compile the native libozw_ext.so library for the zwave package.
Finally, run the included command line application to ensure that this package is installed correctly and can communicate with your devices using your Z-Wave Controller.
Add this to your package's pubspec.yaml file:
dependencies: zwave: ^0.8.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.8.0||Jul 5, 2017|
|0.7.0||Dec 27, 2016|
|0.6.0||Aug 8, 2016|
|0.5.0||Jul 29, 2016|
|0.3.0||Jul 23, 2016|
|0.2.0||Jul 16, 2016|
|0.1.3||Jul 2, 2016|
|0.1.2||Jun 19, 2016|
|0.1.1||May 31, 2016|
|0.1.0||May 31, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.15.0 <2.0.0|